QUE API — some 504 gateway timeouts

Incident Report for Dataclay

Resolved

After investigation, we resolved an issue causing slowdowns and some timeouts in job logging queries. We also added rules to mitigate a series of malformed requests that were not successfully connecting to QUE endpoints, but were also slowing or causing some timeouts for QUE user clients. This appears to have resolved the issues we were seeing. If you continue to experience any connection timeouts, please contact Dataclay support.
Posted May 16, 2025 - 10:42 CDT

Monitoring

After investigating the timeout issue with the QUE API endpoints, we have identified two possible causes. We have issued a fix and are monitoring activity.
Posted May 15, 2025 - 09:47 CDT

Investigating

We are investigating some QUE API gateway timeouts on the /jobs endpoint. We will update as we discover more information.
Posted May 14, 2025 - 12:07 CDT
This incident affected: Dataclay QUE (API).