Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 24, 2026 - 21:00 CDT
Scheduled
We will be deploying an update to the QUE Dashboard and QUE API tonight, on [date] beginning at 9PM ET. Both the QUE Dashboard and QUE API may be unavailable for up to a two hour maintenance window, though it should be much short than that.
NOTE: New QUE log retention policy
With this release, QUE job logs are permanently deleted 120 days after the date they are created. This applies to existing logs as well as all logs created going forward. Logs currently older than 120 days will be removed as part of this change, and deleted logs cannot be recovered. If you need to retain log data beyond 120 days, please send us an email before September 3, 2026 at support@dataclay.com and we can export them for you.
Also included in this release
- Security: upgraded the both front-end and back-end framworks to comply with security audits - Fixed several crash conditions in the Dashboard - Improved the flow for inviting users to an organization - Added a Changelog dialog showing what has changed in each release - A number of small visual fixes across the Dashboard
We will update this post once the deployment is complete. If you have questions about the retention policy or need help exporting logs, contact support@dataclay.com
Thank you for your understanding as we continue to upgrade the QUE platform.
Posted Aug 24, 2026 - 11:44 CDT
This scheduled maintenance affected: Dataclay QUE (Dashboard, API, Database).